Windows 10 Home edition gives you little control of Windows Update but try this
Run either Windows PowerShell or Command Prompt as administrator. you can find them from start menu and right click on one of them and run as a administrator.
In PowerShell or Command Prompt type the following command sc.exe config wuauserv start= disabled then press Enter
success message should displayed. now just close the window.

you can confirm that Windows Update is disabled by visiting the Updates section of the settings app and clicking on Check for updates. It should fail.

I hope this will work. do it on your own risk.